Should the plugin LaggRemover be updated to Spigot 1.8.4?

Yes, update to Spigot 1.8.4 17

I don't really care... 4

No, stay Spigot 1.8.3 2

23 Votes

0 Comments

Vote