After February 20th 2018, all embed and API requests to strawpoll.me must use a secure connection (https).

What console are you buying and what do you own currently?

Xbox 360 --> PS4 1

Xbox 360 --> Xbone 1

PS3 --> PS4 0

PS3 --> Xbone 0

2 Votes

0 Comments

Vote