After February 20th 2018, all embed and API requests to strawpoll.me must use a secure connection (https).

Do you want the ESL Go4 Series to start before or after release?

Results