After February 20th 2018, all embed and API requests to strawpoll.me must use a secure connection (https).

Are you going to subscribe for Netlink Trust ?

Yes, it is a no brainer! Everyone needs broadband! 478

Maybe... wanted to but Mr. IPO gives only 1 Chilli... 412

No way! There are better yielding stuff.. 152

1042 Votes

0 Comments

Vote