After February 20th 2018, all embed and API requests to strawpoll.me must use a secure connection (https).

Meme's on the subreddit?

In moderation (moderated more but not removed fully) 66

No 43

Yes 41

I don't really mind 32

182 Votes

0 Comments

Vote