After February 20th 2018, all embed and API requests to strawpoll.me must use a secure connection (https).

Do you use the built-in Rift headphones?

Yes! 164

No, I took them off. 23

187 Votes

0 Comments

Vote